You need flash plug-in 9.0.45 or higher. Download it here